同花顺公式 - 翼展电脑服务中心


新发现的一个同花顺指标,比较准确

2018-3-16 乱云飞 代码 评论(0) 浏览(697) 标签: 同花顺公式 钱袋指标

持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,colorblue; 
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,colorred; 
{}
ZT:=C/REF(C,1)>1.097;
ZTBPJ:=REF(C,BARSLAST(ZT)+1)*0.98;//{涨停不破价}
ZTBP:=BARSLAST(ZT)<30 AND (LLV(C,BARSLAST(ZT))>=ZTBPJ OR
LLV(C,BARSLAST(ZT))=ZTBPJ);//{涨停不破价}
STICKLINE(ZTBP,REF(C,BARSLAST(ZT)+1)-REF(C,BARSLAST(ZT)+1)*0.001,REF(C,BARSLAST(ZT)+1),1,0),coloryellow;
DRAWTEXT(ZT,L*0.98,'涨停'),colorlimagenta;
不破价:=REF(L,BARSLAST(ZT));
LS0:=BARSLAST(ZT);LS11:=IF(2,LS0=2,ZT);
LS21:=IF(2,LLV(L,2)>REF(L,2),1);
ZT不破2:=LS11 AND LS21;
DRAWTEXT(ZT不破2,不破价-不破价*0.02,'3'),colorgreen;
LS14:=IF(4,LS0=4,ZT);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
ZT不破4:=LS14 AND LS24;
DRAWTEXT(ZT不破4,不破价-不破价*0.02,'5'),colorgreen;
LS17:=IF(7,LS0=7,ZT);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
ZT不破7:=LS17 AND LS27;
DRAWTEXT(ZT不破7,不破价-不破价*0.02,'8'),colorgreen;
LS22:=IF(12,LS0=12,ZT);
LS32:=IF(12,LLV(L,12)>REF(L,12),1);
ZT不破12:=LS22 AND LS32;
DRAWTEXT(ZT不破12,不破价-不破价*0.02,'13'),colorgreen;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
迫线:=C>O AND V>REF(V,1)  AND L>REF(C,1) AND REF(ZT,1);
小阳:=C>O AND V>REF(V,1) AND REF(ZT,1);
起爆:=REF(HHV(V,8),1)/V>=1.97 AND REF(HHV(小阳,8),1)  AND C>O;
STICKLINE(ZT,REF(O,BH),REF(C,BH),2,0),coloryellow;
DRAWTEXT(ZT,L*0.98,'涨停'),COLORF00FF0;
STICKLINE(迫线,O,C,2,0),colormagenta;
DRAWTEXT(迫线,L*0.98,'迫'),COLORF00FF0;
DRAWICON(小阳,LOW*0.995,25);
DRAWTEXT(起爆,L*0.92,'爆'),colorred;
Q:=MA(C,2);
OK:=CROSS(Q,REF(Q,1)) AND REF(HHV(ZT,8),1);
DRAWTEXT(OK,L,'★拐点'),colorred; 
O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK0;
O2:EMA(O1,3),COLORFF00FF,LINETHICK0;
O3:EMA(O2,3),COLOR00FF00,LINETHICK0;
MMM:=MA(CLOSE,20);
PEAK1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR21:=REF(PEAK1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR31:=REF(VAR21,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR31,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND PEAK1;
VAR1A:=REF(PEAK1 OR VAR21 OR VAR31 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
{STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;}
DRAWICON(FILTER(VAR19=1,5),LOW*0.995,9);
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.008,0);
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.03,15);
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,12),HIGH,LOW<=LLV(LOW,12),HHV(HIGH,4),1),LINETHICK1,COLOR00BC00;
上涨支撑线:DRAWLINE(LOW<=LLV(LOW,12),LOW,HIGH>=HHV(HIGH,4),LLV(LOW,4),1),LINETHICK1,colorwhite;
DRAWNUMBER(ISLASTBAR,上涨支撑线,上涨支撑线),coloryellow;股票

//洛阳翼展电脑牛魔王指针优化版,副图20171130V1.1调整了颜色

2017-11-30 乱云飞 代码 评论(0) 浏览(916) 标签: 同花顺公式 牛魔王指针

//洛阳翼展电脑牛魔王指针优化版,副图20171130V1.1调整了颜色
//蓝色:【卖出信号】
//红色:【买入信号】
//白色:【极度虚弱赌反弹风险高】
//黄色:【虚弱赌反弹准确率高】
//绿虚:【卖出信号,上方圆圈越多信号越强烈】
//黄虚:【买入信号】
//红虚:【买入信号加强】

九转叠加进K线

2017-10-31 乱云飞 代码 评论(0) 浏览(846) 标签: 九转序列 同花顺公式

T1=BARSLASTCOUNT(C<REF(C,4));
T2=BARSLASTCOUNT(C>REF(C,4));
STICKLINE(T1=8,L*0.96,0,9,0),coloryellow;//低八黄色预备
STICKLINE(T1=9,L*0.96,0,9,0),colorred;//低九红色买入
STICKLINE(T2=8,L*0.96,0,9,0),colorCCCCCC;//高八白色预警
STICKLINE(T2=9,L*0.96,0,9,0),colorgreen;//高九绿色卖出

九转精简版带预警。

2017-10-31 乱云飞 代码 评论(0) 浏览(865) 标签: 九转序列 同花顺公式

T1=BARSLASTCOUNT(C<REF(C,4));
T2=BARSLASTCOUNT(C>REF(C,4));
STICKLINE(T1=8,0.5,0,9,0),coloryellow;//低八黄色预备
STICKLINE(T1=9,0.5,0,9,0),colorred;//低九红色买入
STICKLINE(T2=8,0.5,0,9,0),colorFFFFFF;//高八白色预警
STICKLINE(T2=9,0.5,0,9,0),colorgreen;//高九绿色卖出

通达信转九选股公式及解释

2017-10-30 乱云飞 代码 评论(0) 浏览(916) 标签: 九转序列 同花顺公式 选股

A1:=C>=REF(C,4);
A:=C<REF(C,4);
AA:=C<REF(C,4) AND REF(A1,1);
T:=BARSLAST(AA);
M:=(T=0 AND REFX(T=1 AND NOT(A),1)) OR (REFX(T=2 AND NOT(A),2)) OR (REFX(T=3 AND NOT(A),3)) OR (REFX(T=4 AND NOT(A),4)) OR (REFX(T=5 AND NOT(A),5)) 
OR (REFX(T=6 AND NOT(A),6)) OR (REFX(T=7 AND NOT(A),7)) OR (REFX(T=8 AND NOT(A),8));
M1:=T=1 AND REFX(T=2 AND NOT(A),1) OR (REFX(T=3 AND NOT(A),2)) OR (REFX(T=4 AND NOT(A),3)) OR (REFX(T=5 AND NOT(A),4)) OR (REFX(T=6 AND NOT(A),5))
OR (REFX(T=7 AND NOT(A),6)) OR (REFX(T=8 AND NOT(A),7));
M2:=T=2 AND REFX(T=3 AND NOT(A),1) OR (REFX(T=4 AND NOT(A),2)) OR (REFX(T=5 AND NOT(A),3)) OR (REFX(T=6 AND NOT(A),4)) OR (REFX(T=7 AND NOT(A),5)) OR (REFX(T=8 AND NOT(A),6));
M3:=T=3 AND REFX(T=4 AND NOT(A),1)OR (REFX(T=5 AND NOT(A),2)) OR (REFX(T=6 AND NOT(A),3)) OR (REFX(T=7 AND NOT(A),4))  OR (REFX(T=8 AND NOT(A),5));
M4:=T=4 AND REFX(T=5 AND NOT(A),1) OR (REFX(T=6 AND NOT(A),2)) OR (REFX(T=7 AND NOT(A),3)) OR (REFX(T=8 AND NOT(A),4));
M5:=T=5 AND  REFX(T=6 AND NOT(A),1) OR (REFX(T=7 AND NOT(A),2)) OR (REFX(T=8 AND NOT(A),3));
M6:=T=6  AND  REFX(T=7 AND NOT(A),1) OR (REFX(T=8 AND NOT(A),2));
M7:=T=7  AND  REFX(T=8 AND NOT(A),1);
N:=T=1 AND REF(T=0 AND AA,1) AND A;
N1:=T=2 AND REF(N,1) AND A;
N2:=T=3 AND REF(N1,1) AND A;
N3:=T=4 AND REF(N2,1) AND A;
N4:=T=5 AND REF(N3,1) AND A;
N5:=T=6 AND REF(N4,1) AND A;
N6:=T=7 AND REF(N5,1) AND A;
N7:=T=8 AND REF(N6,1) AND A;
DI:IF(N7,1,0),LINETHICK3,COLORRED;
----------------------------------------------------------------------------------------
A1赋值:收盘价>=4日前的收盘价
A赋值:收盘价<4日前的收盘价
AA赋值:收盘价<4日前的收盘价 AND 1日前的A1
T赋值:上次AA距今天数
M赋值:(T=0 AND 1日后的T=1ANDNOT(A)) OR (2日后的T=2ANDNOT(A)) OR (3日后的T=3ANDNOT(A)) OR (4日后的T=4ANDNOT(A)) OR (5日后的T=5ANDNOT(A)) OR (6日后的T=6ANDNOT(A)) OR (7日后的T=7ANDNOT(A)) OR (8日后的T=8ANDNOT(A))
M1赋值:T=1 AND 1日后的T=2ANDNOT(A) OR (2日后的T=3ANDNOT(A)) OR (3日后的T=4ANDNOT(A)) OR (4日后的T=5ANDNOT(A)) OR (5日后的T=6ANDNOT(A))OR (6日后的T=7ANDNOT(A)) OR (7日后的T=8ANDNOT(A))
M2赋值:T=2 AND 1日后的T=3ANDNOT(A) OR (2日后的T=4ANDNOT(A)) OR (3日后的T=5ANDNOT(A)) OR (4日后的T=6ANDNOT(A)) OR (5日后的T=7ANDNOT(A)) OR (6日后的T=8ANDNOT(A))
M3赋值:T=3 AND 1日后的T=4ANDNOT(A)OR (2日后的T=5ANDNOT(A)) OR (3日后的T=6ANDNOT(A)) OR (4日后的T=7ANDNOT(A))  OR (5日后的T=8ANDNOT(A))
M4赋值:T=4 AND 1日后的T=5ANDNOT(A) OR (2日后的T=6ANDNOT(A)) OR (3日后的T=7ANDNOT(A)) OR (4日后的T=8ANDNOT(A))
M5赋值:T=5 AND  1日后的T=6ANDNOT(A) OR (2日后的T=7ANDNOT(A)) OR (3日后的T=8ANDNOT(A))
M6赋值:T=6  AND  1日后的T=7ANDNOT(A) OR (2日后的T=8ANDNOT(A))
M7赋值:T=7  AND  1日后的T=8ANDNOT(A)
N赋值:T=1 AND 1日前的T=0ANDAA AND A
N1赋值:T=2 AND 1日前的N AND A
N2赋值:T=3 AND 1日前的N1 AND A
N3赋值:T=4 AND 1日前的N2 AND A
N4赋值:T=5 AND 1日前的N3 AND A
N5赋值:T=6 AND 1日前的N4 AND A
N6赋值:T=7 AND 1日前的N5 AND A
N7赋值:T=8 AND 1日前的N6 AND A
输出DI:如果N7,返回1,否则返回0,线宽为3,画红色

下跌出九公式精简写法

2017-10-30 乱云飞 代码 评论(0) 浏览(984) 标签: 九转序列 同花顺公式

//下跌出九公式精简写法
B1:=C<REF(C,4);
B2:=BARSLASTCOUNT(B1);
下跌出九:B2=9,STICK,colorred,LINETHICK3;
//---------------------------------------------
//合并成一行
T1=BARSLASTCOUNT(C<REF(C,4));
下跌出九:T1=9,STICK,colorred,LINETHICK5;

徐小明九转源码

2017-10-25 乱云飞 代码 评论(0) 浏览(1021) 标签: 九转序列 同花顺公式 徐小明

A1:=C>REF(C,4);
A2:=C<REF(C,4);
T1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);
T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);
T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
T10:=A2 AND REF(T9,1);
T11:=A2 AND REF(T10,1);
T12:=A2 AND REF(T11,1);
T13:=A2 AND REF(T12,1);
T14:=A2 AND REF(T13,1);
DRAWTEXT(T1,L*0.98,'1'),colorgreen;
DRAWTEXT(T2,L*0.98,'2'),colorgreen;
DRAWTEXT(T3,L*0.98,'3'),colorgreen;
DRAWTEXT(T4,L*0.98,'4'),colorgreen;
DRAWTEXT(T5,L*0.98,'5'),colorgreen;
DRAWTEXT(T6,L*0.98,'6'),colorgreen;
DRAWTEXT(T7,L*0.98,'7'),colorgreen;
DRAWTEXT(T8,L*0.98,'8'),colorgreen;
DRAWTEXT(T9,L*0.98,'9'),colorblue;
B1:=C<REF(C,4);
B2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
D3:=B2 AND REF(D2,1);
D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);
D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
D10:=B2 AND REF(D9,1);
D11:=B2 AND REF(D10,1);
D12:=B2 AND REF(D11,1);
D13:=B2 AND REF(D12,1);
D14:=B2 AND REF(D13,1);
DRAWTEXT(D1,H*1.010,'1'),colorblue;
DRAWTEXT(D2,H*1.010,'2'),colorblue;
DRAWTEXT(D3,H*1.010,'3'),colorblue;
DRAWTEXT(D4,H*1.010,'4'),colorblue;
DRAWTEXT(D5,H*1.010,'5'),colorblue;
DRAWTEXT(D6,H*1.010,'6'),colorblue;
DRAWTEXT(D7,H*1.010,'7'),colorblue;
DRAWTEXT(D8,H*1.010,'8'),colorblue;
DRAWTEXT(D9,H*1.010,'9'),colorgreen;

威廉指标详解

2017-9-15 乱云飞 评论(0) 浏览(953) 标签: 同花顺公式 威廉指标

WR1:100*(HHV(HIGH,N)-CLOSE)/(HHV(HIGH,N)-LLV(LOW,N));
WR2:100*(HHV(HIGH,N1)-CLOSE)/(HHV(HIGH,N1)-LLV(LOW,N1));
a:n2;

d:n3;


参数    最小    最大    默认

N    2    100    10

N1    2    100    6

(求最高值(最高价,N)-收盘价)/(求最高值(最高价,N)-求最低值(最低价,N))

(求最高值(最高价,N1)-收盘价)/(求最高值(最高价,N1)-求最低值(最低价,N1))

预ICP备10086-001号 © 翼展网/80C.CC 技术支持/洛阳翼展科技
TEL / 13213610060 QQ / 345794501
Powered by emlog