新发现的一个同花顺指标,比较准确 - 洛阳翼展电脑


新发现的一个同花顺指标,比较准确

2018-3-16 乱云飞 代码 标签: 同花顺公式 钱袋指标

持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,colorblue; 
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,colorred; 
{}
ZT:=C/REF(C,1)>1.097;
ZTBPJ:=REF(C,BARSLAST(ZT)+1)*0.98;//{涨停不破价}
ZTBP:=BARSLAST(ZT)<30 AND (LLV(C,BARSLAST(ZT))>=ZTBPJ OR
LLV(C,BARSLAST(ZT))=ZTBPJ);//{涨停不破价}
STICKLINE(ZTBP,REF(C,BARSLAST(ZT)+1)-REF(C,BARSLAST(ZT)+1)*0.001,REF(C,BARSLAST(ZT)+1),1,0),coloryellow;
DRAWTEXT(ZT,L*0.98,'涨停'),colorlimagenta;
不破价:=REF(L,BARSLAST(ZT));
LS0:=BARSLAST(ZT);LS11:=IF(2,LS0=2,ZT);
LS21:=IF(2,LLV(L,2)>REF(L,2),1);
ZT不破2:=LS11 AND LS21;
DRAWTEXT(ZT不破2,不破价-不破价*0.02,'3'),colorgreen;
LS14:=IF(4,LS0=4,ZT);
LS24:=IF(4,LLV(L,4)>REF(L,4),1);
ZT不破4:=LS14 AND LS24;
DRAWTEXT(ZT不破4,不破价-不破价*0.02,'5'),colorgreen;
LS17:=IF(7,LS0=7,ZT);
LS27:=IF(7,LLV(L,7)>REF(L,7),1);
ZT不破7:=LS17 AND LS27;
DRAWTEXT(ZT不破7,不破价-不破价*0.02,'8'),colorgreen;
LS22:=IF(12,LS0=12,ZT);
LS32:=IF(12,LLV(L,12)>REF(L,12),1);
ZT不破12:=LS22 AND LS32;
DRAWTEXT(ZT不破12,不破价-不破价*0.02,'13'),colorgreen;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
迫线:=C>O AND V>REF(V,1)  AND L>REF(C,1) AND REF(ZT,1);
小阳:=C>O AND V>REF(V,1) AND REF(ZT,1);
起爆:=REF(HHV(V,8),1)/V>=1.97 AND REF(HHV(小阳,8),1)  AND C>O;
STICKLINE(ZT,REF(O,BH),REF(C,BH),2,0),coloryellow;
DRAWTEXT(ZT,L*0.98,'涨停'),COLORF00FF0;
STICKLINE(迫线,O,C,2,0),colormagenta;
DRAWTEXT(迫线,L*0.98,'迫'),COLORF00FF0;
DRAWICON(小阳,LOW*0.995,25);
DRAWTEXT(起爆,L*0.92,'爆'),colorred;
Q:=MA(C,2);
OK:=CROSS(Q,REF(Q,1)) AND REF(HHV(ZT,8),1);
DRAWTEXT(OK,L,'★拐点'),colorred; 
O1:(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLOR00FFFF,LINETHICK0;
O2:EMA(O1,3),COLORFF00FF,LINETHICK0;
O3:EMA(O2,3),COLOR00FF00,LINETHICK0;
MMM:=MA(CLOSE,20);
PEAK1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR21:=REF(PEAK1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR31:=REF(VAR21,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR31,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND PEAK1;
VAR1A:=REF(PEAK1 OR VAR21 OR VAR31 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
{STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;}
DRAWICON(FILTER(VAR19=1,5),LOW*0.995,9);
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.008,0);
DRAWICON(FILTER(VAR1A=1,5),HIGH*1.03,15);
下降压力线:DRAWLINE(HIGH>=HHV(HIGH,12),HIGH,LOW<=LLV(LOW,12),HHV(HIGH,4),1),LINETHICK1,COLOR00BC00;
上涨支撑线:DRAWLINE(LOW<=LLV(LOW,12),LOW,HIGH>=HHV(HIGH,4),LLV(LOW,4),1),LINETHICK1,colorwhite;
DRAWNUMBER(ISLASTBAR,上涨支撑线,上涨支撑线),coloryellow;股票

本文链接:http://80c.cc/ez/105.html

发表评论:

预ICP备10086-001号 © 翼展网/80C.CC 技术支持/洛阳翼展科技
TEL / 13213610060 QQ / 345794501
Powered by emlog