九转序列 - 翼展电脑服务中心


九转叠加进K线

2017-10-31 乱云飞 代码 评论(0) 浏览(847) 标签: 九转序列 同花顺公式

T1=BARSLASTCOUNT(C<REF(C,4));
T2=BARSLASTCOUNT(C>REF(C,4));
STICKLINE(T1=8,L*0.96,0,9,0),coloryellow;//低八黄色预备
STICKLINE(T1=9,L*0.96,0,9,0),colorred;//低九红色买入
STICKLINE(T2=8,L*0.96,0,9,0),colorCCCCCC;//高八白色预警
STICKLINE(T2=9,L*0.96,0,9,0),colorgreen;//高九绿色卖出

九转精简版带预警。

2017-10-31 乱云飞 代码 评论(0) 浏览(866) 标签: 九转序列 同花顺公式

T1=BARSLASTCOUNT(C<REF(C,4));
T2=BARSLASTCOUNT(C>REF(C,4));
STICKLINE(T1=8,0.5,0,9,0),coloryellow;//低八黄色预备
STICKLINE(T1=9,0.5,0,9,0),colorred;//低九红色买入
STICKLINE(T2=8,0.5,0,9,0),colorFFFFFF;//高八白色预警
STICKLINE(T2=9,0.5,0,9,0),colorgreen;//高九绿色卖出

通达信转九选股公式及解释

2017-10-30 乱云飞 代码 评论(0) 浏览(918) 标签: 九转序列 同花顺公式 选股

A1:=C>=REF(C,4);
A:=C<REF(C,4);
AA:=C<REF(C,4) AND REF(A1,1);
T:=BARSLAST(AA);
M:=(T=0 AND REFX(T=1 AND NOT(A),1)) OR (REFX(T=2 AND NOT(A),2)) OR (REFX(T=3 AND NOT(A),3)) OR (REFX(T=4 AND NOT(A),4)) OR (REFX(T=5 AND NOT(A),5)) 
OR (REFX(T=6 AND NOT(A),6)) OR (REFX(T=7 AND NOT(A),7)) OR (REFX(T=8 AND NOT(A),8));
M1:=T=1 AND REFX(T=2 AND NOT(A),1) OR (REFX(T=3 AND NOT(A),2)) OR (REFX(T=4 AND NOT(A),3)) OR (REFX(T=5 AND NOT(A),4)) OR (REFX(T=6 AND NOT(A),5))
OR (REFX(T=7 AND NOT(A),6)) OR (REFX(T=8 AND NOT(A),7));
M2:=T=2 AND REFX(T=3 AND NOT(A),1) OR (REFX(T=4 AND NOT(A),2)) OR (REFX(T=5 AND NOT(A),3)) OR (REFX(T=6 AND NOT(A),4)) OR (REFX(T=7 AND NOT(A),5)) OR (REFX(T=8 AND NOT(A),6));
M3:=T=3 AND REFX(T=4 AND NOT(A),1)OR (REFX(T=5 AND NOT(A),2)) OR (REFX(T=6 AND NOT(A),3)) OR (REFX(T=7 AND NOT(A),4))  OR (REFX(T=8 AND NOT(A),5));
M4:=T=4 AND REFX(T=5 AND NOT(A),1) OR (REFX(T=6 AND NOT(A),2)) OR (REFX(T=7 AND NOT(A),3)) OR (REFX(T=8 AND NOT(A),4));
M5:=T=5 AND  REFX(T=6 AND NOT(A),1) OR (REFX(T=7 AND NOT(A),2)) OR (REFX(T=8 AND NOT(A),3));
M6:=T=6  AND  REFX(T=7 AND NOT(A),1) OR (REFX(T=8 AND NOT(A),2));
M7:=T=7  AND  REFX(T=8 AND NOT(A),1);
N:=T=1 AND REF(T=0 AND AA,1) AND A;
N1:=T=2 AND REF(N,1) AND A;
N2:=T=3 AND REF(N1,1) AND A;
N3:=T=4 AND REF(N2,1) AND A;
N4:=T=5 AND REF(N3,1) AND A;
N5:=T=6 AND REF(N4,1) AND A;
N6:=T=7 AND REF(N5,1) AND A;
N7:=T=8 AND REF(N6,1) AND A;
DI:IF(N7,1,0),LINETHICK3,COLORRED;
----------------------------------------------------------------------------------------
A1赋值:收盘价>=4日前的收盘价
A赋值:收盘价<4日前的收盘价
AA赋值:收盘价<4日前的收盘价 AND 1日前的A1
T赋值:上次AA距今天数
M赋值:(T=0 AND 1日后的T=1ANDNOT(A)) OR (2日后的T=2ANDNOT(A)) OR (3日后的T=3ANDNOT(A)) OR (4日后的T=4ANDNOT(A)) OR (5日后的T=5ANDNOT(A)) OR (6日后的T=6ANDNOT(A)) OR (7日后的T=7ANDNOT(A)) OR (8日后的T=8ANDNOT(A))
M1赋值:T=1 AND 1日后的T=2ANDNOT(A) OR (2日后的T=3ANDNOT(A)) OR (3日后的T=4ANDNOT(A)) OR (4日后的T=5ANDNOT(A)) OR (5日后的T=6ANDNOT(A))OR (6日后的T=7ANDNOT(A)) OR (7日后的T=8ANDNOT(A))
M2赋值:T=2 AND 1日后的T=3ANDNOT(A) OR (2日后的T=4ANDNOT(A)) OR (3日后的T=5ANDNOT(A)) OR (4日后的T=6ANDNOT(A)) OR (5日后的T=7ANDNOT(A)) OR (6日后的T=8ANDNOT(A))
M3赋值:T=3 AND 1日后的T=4ANDNOT(A)OR (2日后的T=5ANDNOT(A)) OR (3日后的T=6ANDNOT(A)) OR (4日后的T=7ANDNOT(A))  OR (5日后的T=8ANDNOT(A))
M4赋值:T=4 AND 1日后的T=5ANDNOT(A) OR (2日后的T=6ANDNOT(A)) OR (3日后的T=7ANDNOT(A)) OR (4日后的T=8ANDNOT(A))
M5赋值:T=5 AND  1日后的T=6ANDNOT(A) OR (2日后的T=7ANDNOT(A)) OR (3日后的T=8ANDNOT(A))
M6赋值:T=6  AND  1日后的T=7ANDNOT(A) OR (2日后的T=8ANDNOT(A))
M7赋值:T=7  AND  1日后的T=8ANDNOT(A)
N赋值:T=1 AND 1日前的T=0ANDAA AND A
N1赋值:T=2 AND 1日前的N AND A
N2赋值:T=3 AND 1日前的N1 AND A
N3赋值:T=4 AND 1日前的N2 AND A
N4赋值:T=5 AND 1日前的N3 AND A
N5赋值:T=6 AND 1日前的N4 AND A
N6赋值:T=7 AND 1日前的N5 AND A
N7赋值:T=8 AND 1日前的N6 AND A
输出DI:如果N7,返回1,否则返回0,线宽为3,画红色

下跌出九公式精简写法

2017-10-30 乱云飞 代码 评论(0) 浏览(987) 标签: 九转序列 同花顺公式

//下跌出九公式精简写法
B1:=C<REF(C,4);
B2:=BARSLASTCOUNT(B1);
下跌出九:B2=9,STICK,colorred,LINETHICK3;
//---------------------------------------------
//合并成一行
T1=BARSLASTCOUNT(C<REF(C,4));
下跌出九:T1=9,STICK,colorred,LINETHICK5;

徐小明九转源码

2017-10-25 乱云飞 代码 评论(0) 浏览(1024) 标签: 九转序列 同花顺公式 徐小明

A1:=C>REF(C,4);
A2:=C<REF(C,4);
T1:=A2 AND REF(A1,1);
T2:=A2 AND REF(T1,1);
T3:=A2 AND REF(T2,1);
T4:=A2 AND REF(T3,1);
T5:=A2 AND REF(T4,1);
T6:=A2 AND REF(T5,1);
T7:=A2 AND REF(T6,1);
T8:=A2 AND REF(T7,1);
T9:=A2 AND REF(T8,1);
T10:=A2 AND REF(T9,1);
T11:=A2 AND REF(T10,1);
T12:=A2 AND REF(T11,1);
T13:=A2 AND REF(T12,1);
T14:=A2 AND REF(T13,1);
DRAWTEXT(T1,L*0.98,'1'),colorgreen;
DRAWTEXT(T2,L*0.98,'2'),colorgreen;
DRAWTEXT(T3,L*0.98,'3'),colorgreen;
DRAWTEXT(T4,L*0.98,'4'),colorgreen;
DRAWTEXT(T5,L*0.98,'5'),colorgreen;
DRAWTEXT(T6,L*0.98,'6'),colorgreen;
DRAWTEXT(T7,L*0.98,'7'),colorgreen;
DRAWTEXT(T8,L*0.98,'8'),colorgreen;
DRAWTEXT(T9,L*0.98,'9'),colorblue;
B1:=C<REF(C,4);
B2:=C>REF(C,4);
D1:=B2 AND REF(B1,1);
D2:=B2 AND REF(D1,1);
D3:=B2 AND REF(D2,1);
D4:=B2 AND REF(D3,1);
D5:=B2 AND REF(D4,1);
D6:=B2 AND REF(D5,1);
D7:=B2 AND REF(D6,1);
D8:=B2 AND REF(D7,1);
D9:=B2 AND REF(D8,1);
D10:=B2 AND REF(D9,1);
D11:=B2 AND REF(D10,1);
D12:=B2 AND REF(D11,1);
D13:=B2 AND REF(D12,1);
D14:=B2 AND REF(D13,1);
DRAWTEXT(D1,H*1.010,'1'),colorblue;
DRAWTEXT(D2,H*1.010,'2'),colorblue;
DRAWTEXT(D3,H*1.010,'3'),colorblue;
DRAWTEXT(D4,H*1.010,'4'),colorblue;
DRAWTEXT(D5,H*1.010,'5'),colorblue;
DRAWTEXT(D6,H*1.010,'6'),colorblue;
DRAWTEXT(D7,H*1.010,'7'),colorblue;
DRAWTEXT(D8,H*1.010,'8'),colorblue;
DRAWTEXT(D9,H*1.010,'9'),colorgreen;
预ICP备10086-001号 © 翼展网/80C.CC 技术支持/洛阳翼展科技
TEL / 13213610060 QQ / 345794501
Powered by emlog