通达信转九选股公式及解释 - 洛阳翼展电脑


通达信转九选股公式及解释

2017-10-30 乱云飞 代码 标签: 九转序列 同花顺公式 选股

A1:=C>=REF(C,4);
A:=C<REF(C,4);
AA:=C<REF(C,4) AND REF(A1,1);
T:=BARSLAST(AA);
M:=(T=0 AND REFX(T=1 AND NOT(A),1)) OR (REFX(T=2 AND NOT(A),2)) OR (REFX(T=3 AND NOT(A),3)) OR (REFX(T=4 AND NOT(A),4)) OR (REFX(T=5 AND NOT(A),5)) 
OR (REFX(T=6 AND NOT(A),6)) OR (REFX(T=7 AND NOT(A),7)) OR (REFX(T=8 AND NOT(A),8));
M1:=T=1 AND REFX(T=2 AND NOT(A),1) OR (REFX(T=3 AND NOT(A),2)) OR (REFX(T=4 AND NOT(A),3)) OR (REFX(T=5 AND NOT(A),4)) OR (REFX(T=6 AND NOT(A),5))
OR (REFX(T=7 AND NOT(A),6)) OR (REFX(T=8 AND NOT(A),7));
M2:=T=2 AND REFX(T=3 AND NOT(A),1) OR (REFX(T=4 AND NOT(A),2)) OR (REFX(T=5 AND NOT(A),3)) OR (REFX(T=6 AND NOT(A),4)) OR (REFX(T=7 AND NOT(A),5)) OR (REFX(T=8 AND NOT(A),6));
M3:=T=3 AND REFX(T=4 AND NOT(A),1)OR (REFX(T=5 AND NOT(A),2)) OR (REFX(T=6 AND NOT(A),3)) OR (REFX(T=7 AND NOT(A),4))  OR (REFX(T=8 AND NOT(A),5));
M4:=T=4 AND REFX(T=5 AND NOT(A),1) OR (REFX(T=6 AND NOT(A),2)) OR (REFX(T=7 AND NOT(A),3)) OR (REFX(T=8 AND NOT(A),4));
M5:=T=5 AND  REFX(T=6 AND NOT(A),1) OR (REFX(T=7 AND NOT(A),2)) OR (REFX(T=8 AND NOT(A),3));
M6:=T=6  AND  REFX(T=7 AND NOT(A),1) OR (REFX(T=8 AND NOT(A),2));
M7:=T=7  AND  REFX(T=8 AND NOT(A),1);
N:=T=1 AND REF(T=0 AND AA,1) AND A;
N1:=T=2 AND REF(N,1) AND A;
N2:=T=3 AND REF(N1,1) AND A;
N3:=T=4 AND REF(N2,1) AND A;
N4:=T=5 AND REF(N3,1) AND A;
N5:=T=6 AND REF(N4,1) AND A;
N6:=T=7 AND REF(N5,1) AND A;
N7:=T=8 AND REF(N6,1) AND A;
DI:IF(N7,1,0),LINETHICK3,COLORRED;
----------------------------------------------------------------------------------------
A1赋值:收盘价>=4日前的收盘价
A赋值:收盘价<4日前的收盘价
AA赋值:收盘价<4日前的收盘价 AND 1日前的A1
T赋值:上次AA距今天数
M赋值:(T=0 AND 1日后的T=1ANDNOT(A)) OR (2日后的T=2ANDNOT(A)) OR (3日后的T=3ANDNOT(A)) OR (4日后的T=4ANDNOT(A)) OR (5日后的T=5ANDNOT(A)) OR (6日后的T=6ANDNOT(A)) OR (7日后的T=7ANDNOT(A)) OR (8日后的T=8ANDNOT(A))
M1赋值:T=1 AND 1日后的T=2ANDNOT(A) OR (2日后的T=3ANDNOT(A)) OR (3日后的T=4ANDNOT(A)) OR (4日后的T=5ANDNOT(A)) OR (5日后的T=6ANDNOT(A))OR (6日后的T=7ANDNOT(A)) OR (7日后的T=8ANDNOT(A))
M2赋值:T=2 AND 1日后的T=3ANDNOT(A) OR (2日后的T=4ANDNOT(A)) OR (3日后的T=5ANDNOT(A)) OR (4日后的T=6ANDNOT(A)) OR (5日后的T=7ANDNOT(A)) OR (6日后的T=8ANDNOT(A))
M3赋值:T=3 AND 1日后的T=4ANDNOT(A)OR (2日后的T=5ANDNOT(A)) OR (3日后的T=6ANDNOT(A)) OR (4日后的T=7ANDNOT(A))  OR (5日后的T=8ANDNOT(A))
M4赋值:T=4 AND 1日后的T=5ANDNOT(A) OR (2日后的T=6ANDNOT(A)) OR (3日后的T=7ANDNOT(A)) OR (4日后的T=8ANDNOT(A))
M5赋值:T=5 AND  1日后的T=6ANDNOT(A) OR (2日后的T=7ANDNOT(A)) OR (3日后的T=8ANDNOT(A))
M6赋值:T=6  AND  1日后的T=7ANDNOT(A) OR (2日后的T=8ANDNOT(A))
M7赋值:T=7  AND  1日后的T=8ANDNOT(A)
N赋值:T=1 AND 1日前的T=0ANDAA AND A
N1赋值:T=2 AND 1日前的N AND A
N2赋值:T=3 AND 1日前的N1 AND A
N3赋值:T=4 AND 1日前的N2 AND A
N4赋值:T=5 AND 1日前的N3 AND A
N5赋值:T=6 AND 1日前的N4 AND A
N6赋值:T=7 AND 1日前的N5 AND A
N7赋值:T=8 AND 1日前的N6 AND A
输出DI:如果N7,返回1,否则返回0,线宽为3,画红色

本文链接:http://80c.cc/ez/96.html

发表评论:

预ICP备10086-001号 © 翼展网/80C.CC 技术支持/洛阳翼展科技
TEL / 13213610060 QQ / 345794501
Powered by emlog